Registrierung Mitgliederliste Administratoren und Moderatoren Suche Häufig gestellte Fragen Zur Startseite  

DsChAeK Forum » dboxTV » Fehler/Probleme und Fragen » [beantwortet->VLC08-Problem] System-Auslastung bringt dboxTV ins hackeln->aufhängen » Hallo Gast [anmelden|registrieren]
Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Seiten (2): [1] 2 nächste » Neues Thema erstellen Antwort erstellen
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
DsChAeK DsChAeK ist männlich
Administrator




Dabei seit: 14.09.2007
Beiträge: 1403

System-Auslastung bringt dboxTV ins hackeln->aufhängen Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

s.
http://forum.dschaek.de/thread.php?postid=1172#post1172

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2

26.01.2009 21:42 DsChAeK ist offline Email an DsChAeK senden Homepage von DsChAeK Beiträge von DsChAeK suchen Nehmen Sie DsChAeK in Ihre Freundesliste auf
DsChAeK DsChAeK ist männlich
Administrator




Dabei seit: 14.09.2007
Beiträge: 1403

Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

Zitat:
Danke erstmal für deine rasche Antwort.
Was ich vergessen habe zu erwähnen.
Wenn der Balken anfängt Rot zu werden dann hilft Strg+R also ein Reset.
Das funktioniert allerdings nicht mehr wenn sich DboxTV vollständig aufgehangen
hat was ich aber nur unter Priority HIGH feststellen konnte.

Um es nochmal zusammen zu fassen:
Starte ich DboxTV mit HIGH-Flag im UDP-Modus dann hängt sich DboxTV
nach einiger Zeit auf wärend ich paralell weiter Arbeite (Surfen, eMails schreiben usw.).
Im UDP-Modus mit NORMAL-Flag fängt es früher an zu ruckeln aber DboxTV
hängt sich nicht auf und das ruckeln lässt sich wieder Temporär mit Strg+R beheben (Balken wird wieder Grün).

Hängt sich DboxTV auf (Priority HIGH) dann nimmt es meist das ganze System mit.
Sprich das System reagiert nicht bzw. kaum mehr.
Dafür ruckelt das Bild nicht bzw. sehr selten anders als im UDP-Modus mit NORMAL-Flag.

Wenn ich allerdings nicht mir dem PC arbeite sprich DboxTV in aller Ruhe laufen lasse
dann tritt o.g. nicht auf. Es läuft quasi wunderbar und ohne Probleme.
Das es an meinem System liegt schließe ich aus weil auf meinem Notebook (Thinkpad) selbiger Fehler auftritt.

Vieleicht hat ja ein anderer User ähnlichs feststellen können?
Da ich viel am PC arbeite benutze ich meinen zweiten Monitor meist für DboxTV
um nebenbei auf dem laufen zu bleiben (N24). Früher habe ich das immer
über das Webinterface gemacht wo das Problem nicht auftritt.
Ich gehe daher von einem Speicherleck in DboxTV aus, es kann aber auch andere Uhrsachen haben.


Gruß
Bt

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2

26.01.2009 22:16 DsChAeK ist offline Email an DsChAeK senden Homepage von DsChAeK Beiträge von DsChAeK suchen Nehmen Sie DsChAeK in Ihre Freundesliste auf
DsChAeK DsChAeK ist männlich
Administrator




Dabei seit: 14.09.2007
Beiträge: 1403

Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

Es könnte immer auch ein VLC Problem sein, da die DLL ja in dboxTV verwendet wird.
Könntest bitte mal in den VLC-Optionen "Timeshift" deaktivieren und testen ob das dann immer noch so ist.
Diese Einstellung hat bei mir schon öfters einen memory leak provoziert, wobei das aber in anderen
Situationen aufgetreten ist.
Was für einen CPU/RAM hast du denn? Ich teste es grad auf meinem 3GHz P4 1GB und merke noch nix bis auf
ein paar "lostbuffers"...bin mal weiter provozieren! smile

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2

26.01.2009 22:24 DsChAeK ist offline Email an DsChAeK senden Homepage von DsChAeK Beiträge von DsChAeK suchen Nehmen Sie DsChAeK in Ihre Freundesliste auf
DsChAeK DsChAeK ist männlich
Administrator




Dabei seit: 14.09.2007
Beiträge: 1403

Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

Kommt der Effekt schneller, wenn du dboxTV einige zeitlang über die Videofläche über den Desktop ziehst?
Das braucht nämlich einiges an CPU, macht bei mir aber bisher auch nix aus...

Wenn der Effekt auftritt, wieviel RAM/CPU verwendet dboxTV? (Taskmanager)

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2

26.01.2009 22:33 DsChAeK ist offline Email an DsChAeK senden Homepage von DsChAeK Beiträge von DsChAeK suchen Nehmen Sie DsChAeK in Ihre Freundesliste auf
Bt




Dabei seit: 28.12.2008
Beiträge: 283

Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

Also,

ich nun mehrmals mit und ohne aktiviertes Timeshift getestet und konnte reproduzierbar feststellen
daß der Rechner bzw. DboxTV sich nur bei bestimmten kanälen z.B. ARD und ZDF aufhängt.
Vieleicht wegen der höheren Bitrate? Das Problem im NORMAL-Modus also das DboxTV
nach einiger Zeit ruckelt ist aber Senderunabhängig.

Zu meinem System, da habe ich genau das gleiche wie Du!
Also auch einen P4HT 3GHz 1GB RD RAM.

Der Effekt tritt Tatsächlich schneller auf wenn ich DboxTV Resize!
Und zwar schon nach 5-10 Sekunden. Teilweise riss der Stream sogar ganz ab
und ich hatte nur noch ein schwarzes Fenster ohne Ton vor mir.
Dann hilft ein Strg+R und der Balken ist wieder grün bzw. das Bild wieder da.

An an der CPU/Speicherauslastung änderte sich indess kaum etwas.
Nur wenn ich Resize dann steigt die CPU-Auslastung enorm an wie Du schon sagtest.
Kann es sein daß ein Programm welches hohe CPU-Auslastung verursacht, den Stream
in DboxTV zum abreißen bringt? Also DboxTV nicht genug Resourcen zur verfügung stehen
um den Stream weiter durchzuschleifen und dann dadurch ins Stottern gerät?


Gruß
Bt

26.01.2009 22:49 Bt ist offline Email an Bt senden Beiträge von Bt suchen Nehmen Sie Bt in Ihre Freundesliste auf
DsChAeK DsChAeK ist männlich
Administrator




Dabei seit: 14.09.2007
Beiträge: 1403

Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

Also ich kann bei mir machen was ich will, ich kann das im Moment nicht reproduzieren.
Könntest du mir mal deine dboxtv.ini schicken? Dann kann ich sicherstellen das wir mit densselben Einstellungen testen.
Ich werde das noch auf meinem Laptop testen.

dboxTV initialisiert mehrere VLC Instanzen, die zusammenarbeiten. Alles was die Wiedergabe und Weiterleitung des original Streams
angeht erledigt VLC selbst. dboxTV prüft nur, in kurzen Abständen, über das VLC-Webinterface, ob der Stream noch läuft und ruft nebenbei noch EPG-Daten der Box ab. So grob gesagt ist das alles was stattfindet.

Ich kann mir das im Moment noch nicht ganz erklären. Erstmal muß ich das nachstellen!

Gruß
DsChAeK

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2

26.01.2009 23:09 DsChAeK ist offline Email an DsChAeK senden Homepage von DsChAeK Beiträge von DsChAeK suchen Nehmen Sie DsChAeK in Ihre Freundesliste auf
Bt




Dabei seit: 28.12.2008
Beiträge: 283

Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

Habe hier mal meine ini angehangen damit du den Fehler vieleicht besser reproduzieren kannst.
Die Log-Datei hab ich auch mit angehangen. Am ende des Logs riss der Stream ganz ab.

Ich habe umgeschaltet, dann ca. 10 sekunden DboxTV groß und klein gezogen bis der Balken rot wurde
aber das Bild noch kam. Kurz darauf habe ich wieder ein paar Sekunden das Fenster groß und klein gemacht
bis schließlich kein Bild und Ton mehr kam. Erst nach Strg+R oder umschalten auf einen anderen Kanal
ging es wieder weiter. Scheinbar ist es für DboxTV doch nicht so gut wenn die CPU stark ausgelastet ist?

Edit1
Sorry habe deinen Post zu spät gelesen sonst hät ich dir das ganze als Email geschickt.
Gut, es kann auch an VLC liegen das stimmt schon. Ich benutze die Version 0.8.6i (Janus).
Aber im Webinterface kommt es ja auch nicht zu diesem Fehler.
/Edit1

Gruß
Bt

code:

[General]
mode=live
ip_pc=192.168.0.10
ip_inet=
broadcastport_udp=31329
streamport_prov=31328
server_port=31327
streamtype=http
priority=NORMAL
sleep_function=Close dboxTV
osdshowtime=5000
dbox_anz=1
providestream=0
compressstream=0
rememberstate=1
autospts=0
fullscreen=0
lock_rc=0
hide_taskbar=0
hide_cursor_on_fs=0
show_message=0
telnet_autologin=0
check_record=0
no_logging=0
no_epgdata=0
no_record_playback=0
use_recm_on_subchannel=1
choose_box_on_start=0
videoonly_noborder=0
draganddrop=1
autoradiorestart=0
disablehotkeys=0
dbox_index=0

[D-Box2_0]
dbox_name=D-Box2
dbox_ip=192.168.0.30
dbox_port=80
dbox_user=root
dbox_pass=dbox2
telnet_port=23
telnet_user=root
telnet_pass=
telnet_nhttpd=nhttpd

[VLC]
libvlcdll=C:\Programme\VideoLAN\VLC\libvlc.dll




vlcip=
vlcport=8080
vlcuser=
vlcpass=
streamport_udp=31338
vlc_rc_port=100
vlc_http_port=120
cacheonline=3500
cachelive=3000
vlc_deinterlace=3
vlc_output=0
vlc_visualize=0
vlc_high_prio=1
online_all_audio_ch=0
timeshift=0
timeshift_path=d:\timeshift\
timeshift_filesize=50

[Online Stream]
vcodec=h264
vbitrate=400
vscale=0.3
vwidth=0
vheight=0
vfps=0,00
acodec=mp3
abitrate=64
achannels=2

[VLC Record]
record_raw=1
file_syntax=%T_%C_%P_-_%I
record_all_audio_ch=0
record_comp_tv=0
record_comp_radio=1
record_path=D:\timeshift
vcodec=DIV3
vbitrate=2048
vscale=0,50
vwidth=0
vheight=0
acodec=mp3
abitrate=128
achannels=2
mux_tv=ASF
mux_radio=RAW
ts=ts
mp3=mp3

[Advanced]
delay_zapto=200
delay_afterosdshot=800
delay_afterosdcmd=800
delay_betweenepgdata=1000
delay_aftervlcpause=0
delay_aftervlcstop=200
delay_aftervlcbasestart=300
delay_aftervlcaddtarget=150
timeout_http=12000
timeout_telnet=2000
thread_updateallradio=10
thread_updatecurrradio=3
menu_break=30

[Window]
monitor=0
height=550
width=583
left=336
top=18
alwaysontop=1
videoonly=0
volume=53

-------------------------------------------LOG-------------------------------------------------

[General]
mode=live
ip_pc=192.168.0.18
ip_inet=
broadcastport_udp=31329
streamport_prov=31328
server_port=31327
streamtype=http
priority=NORMAL
sleep_function=Close dboxTV
osdshowtime=5000
dbox_anz=1
providestream=0
compressstream=0
rememberstate=1
autospts=0
fullscreen=0
lock_rc=0
hide_taskbar=0
hide_cursor_on_fs=0
show_message=0
telnet_autologin=0
check_record=0
no_logging=0
no_epgdata=0
no_record_playback=0
use_recm_on_subchannel=1
choose_box_on_start=0
videoonly_noborder=0
draganddrop=1
autoradiorestart=0
disablehotkeys=0
dbox_index=0

[D-Box2_0]
dbox_name=D-Box2
dbox_ip=192.168.0.100
dbox_port=80
dbox_user=hidden :)
dbox_pass=hidden :)
telnet_port=23
telnet_user=hidden :)
telnet_pass=hidden :)
telnet_nhttpd=nhttpd

[VLC]
libvlcdll=C:\Programme\VideoLAN\VLC\libvlc.dll




vlcip=
vlcport=8080
vlcuser=hidden :)
vlcpass=hidden :)
streamport_udp=31338
vlc_rc_port=100
vlc_http_port=120
cacheonline=3500
cachelive=3000
vlc_deinterlace=3
vlc_output=0
vlc_visualize=0
vlc_high_prio=1
online_all_audio_ch=0
timeshift=0
timeshift_path=d:\timeshift\
timeshift_filesize=50

[Online Stream]
vcodec=h264
vbitrate=400
vscale=0.3
vwidth=0
vheight=0
vfps=0,00
acodec=mp3
abitrate=64
achannels=2

[VLC Record]
record_raw=1
file_syntax=%T_%C_%P_-_%I
record_all_audio_ch=0
record_comp_tv=0
record_comp_radio=1
record_path=D:\timeshift
vcodec=DIV3
vbitrate=2048
vscale=0,50
vwidth=0
vheight=0
acodec=mp3
abitrate=128
achannels=2
mux_tv=ASF
mux_radio=RAW
ts=ts
mp3=mp3

[Advanced]
delay_zapto=200
delay_afterosdshot=800
delay_afterosdcmd=800
delay_betweenepgdata=1000
delay_aftervlcpause=0
delay_aftervlcstop=200
delay_aftervlcbasestart=300
delay_aftervlcaddtarget=150
timeout_http=12000
timeout_telnet=2000
thread_updateallradio=10
thread_updatecurrradio=3
menu_break=30

[Window]
monitor=0
height=390
width=528
left=556
top=2
alwaysontop=1
videoonly=0
volume=53
____________________________________________________________________
22:54:22:843, VLC   , VLC_PlaylistClear(), no error
22:54:22:843, FUNC  , SetDboxMode(TV)
22:54:22:859, HTTP  , [URL]http://192.168.0.100:80/control/zapto?4530001445f,[/URL] no error
22:54:23:109, FUNC  , Delay 200ms
22:54:23:312, VLC   , VLC_VariableGet(conf::audio-track) 0, variable not found
22:54:23:312, VLC   , VLC_VariableSet(conf::audio-track) 0, no error
22:54:23:312, FUNC  , getting subchannels...
22:54:23:312, HTTP  , [URL]http://192.168.0.100:80/control/zapto?getallsubchannels,[/URL] no error
22:54:23:546, STATE , getting streaminfo...
22:54:23:562, HTTP  , [URL]http://192.168.0.100:80/control/info?streaminfo,[/URL] no error
22:54:23:625, HTTP  , [URL]http://192.168.0.100:80/control/zapto?getallpids,[/URL] no error
22:54:23:796, FUNC  , LiveURL: [URL]http://192.168.0.100:31339/0,0x0063,0x03FF,0x0400[/URL]
22:54:23:796, FUNC  , AspectRatio: 16:9
22:54:23:812, FUNC  , PrepareAndStartStream()
22:54:23:812, VLC   , VLC_PlaylistClear(), no error
22:54:23:812, VLC   , Play (vlc_base): [URL]http://192.168.0.100:31339/0,0x0063,0x03FF,0x0400,[/URL] no error
22:54:23:812, FUNC  , Delay 150ms
22:54:23:968, FUNC  , Delay 300ms
22:54:24:281, FUNC  , Delay 150ms
22:54:24:437, VLC   , VLC_MRL_base: :sout=#duplicate{dst=std{access=http,mux=ts,dst=192.168.0.18:31339}}, no error
22:54:24:437, VLC   , VLC_MRL_local: , no error
22:54:24:437, VLC   , VLC_MRL_online: , no error
22:54:24:437, VLC   , Play (vlc_play): [URL]http://192.168.0.18:31339,[/URL] no error
22:54:25:640, STATE , caching...(3000ms)
22:54:28:656, STATE , playing HTTP stream...(720x576/1875kbit/joint stereo)
22:54:28:687, FUNC  , switching time : 6.172s
22:54:32:890, VLC   , lostpictures: 25, no error
22:54:32:921, VLC   , lostbuffers: 38, no error

Dieser Beitrag wurde schon 1 mal editiert, zum letzten mal von Bt am 26.01.2009 23:15.

26.01.2009 23:09 Bt ist offline Email an Bt senden Beiträge von Bt suchen Nehmen Sie Bt in Ihre Freundesliste auf
DsChAeK DsChAeK ist männlich
Administrator




Dabei seit: 14.09.2007
Beiträge: 1403

Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

Super, da hast du echt mitgedacht, Danke fürs Log und Ini-Daten smile
Werde das gleich mal damit testen.

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2

26.01.2009 23:12 DsChAeK ist offline Email an DsChAeK senden Homepage von DsChAeK Beiträge von DsChAeK suchen Nehmen Sie DsChAeK in Ihre Freundesliste auf
Bt




Dabei seit: 28.12.2008
Beiträge: 283

Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

Ok, Danke schonmal für deine bemühungen! smile

Ich werde jetzt auch erstmal ins Bett gehen und dann Morgen nochmal genauer Testen.
Wie gesagt, so schlimm ist das jetzt auch nicht. Wenn der Fehler auftritt dann habe ich bis
jetzt einfach nur Strg+R gedrückt und dann weiter gearbeitet. Nur auf dauer Nervt das eben.

Also dann melde ich mich Morgen nochmal mit neuen Ergebnissen.
Mach Du bitte wegen mir auch nicht mehr so lange!


Danke, Gruß und gute Nacht
Bt

26.01.2009 23:20 Bt ist offline Email an Bt senden Beiträge von Bt suchen Nehmen Sie Bt in Ihre Freundesliste auf
DsChAeK DsChAeK ist männlich
Administrator




Dabei seit: 14.09.2007
Beiträge: 1403

Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

Also auch mit deiner Konfiguration läuft es bei mir stabil.
Könnte auch was mit Image/udpstreamts/box-Einstellungen zu tun haben.
Hast du eigentlich SAT oder Kabel?

dboxTV funktioniert etwas komplizierter wie yWeb, ich werde dir mal genaue Anleitung geben, wie du
manuell das nachstellen kannst was dboxTV mit VLC macht. Dann können wir auschließen das es an VLC liegt.

Mache jetzt auch Schluß! smile

gn8
DsChAeK

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2

26.01.2009 23:25 DsChAeK ist offline Email an DsChAeK senden Homepage von DsChAeK Beiträge von DsChAeK suchen Nehmen Sie DsChAeK in Ihre Freundesliste auf
Bt




Dabei seit: 28.12.2008
Beiträge: 283

Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

Sorry, bin eben erst wieder zuhause angekommen.
Also ich hab natürlich SAT! Augenzwinkern

Kannst mir ja mal die Anleitung geben dann teste ich das Morgen mal damit.

Bis dahin sag ich schonmal gute Nacht


Gruß
Bt

27.01.2009 23:19 Bt ist offline Email an Bt senden Beiträge von Bt suchen Nehmen Sie Bt in Ihre Freundesliste auf
DsChAeK DsChAeK ist männlich
Administrator




Dabei seit: 14.09.2007
Beiträge: 1403

Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

Ok, hab grad wenig Zeit, mach ich im Laufe der Woche irgendwann! smile

gn8
DsChAeK

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2

27.01.2009 23:42 DsChAeK ist offline Email an DsChAeK senden Homepage von DsChAeK Beiträge von DsChAeK suchen Nehmen Sie DsChAeK in Ihre Freundesliste auf
DsChAeK DsChAeK ist männlich
Administrator




Dabei seit: 14.09.2007
Beiträge: 1403

Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

Email mit Testversion ist raus, hoffe es kam an!

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2

31.01.2009 10:56 DsChAeK ist offline Email an DsChAeK senden Homepage von DsChAeK Beiträge von DsChAeK suchen Nehmen Sie DsChAeK in Ihre Freundesliste auf
Bt




Dabei seit: 28.12.2008
Beiträge: 283

Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

Hi,

habe Deine eMail bekommen und eben mal eine Stunde getestet.
Also der Balken bleibt nun grün was denke ich aber daran liegt das er nun "hardcoded" ist.

Die besagten Symptome bleiben zum größten Teil nachwievor.
Ich meine aber nun herausgefunden zu haben das zumindest das Ruckeln
des Bildes und die Tonaussetzer an der hohen Systemlast liegt.

Sprich wenn andere Prozesse zu Hardwarehungrig sind dann kommt dboxTV mit dem Stream nicht mehr hinterher.
VLC scheint dann sozusagen einfach nicht mehr genug Resourcen zu haben um flüssig wiederzugeben.

Trozdem bleibt noch das Problem, daß der Stream bei zu lange anhaltender Systemauslastung
abbreißt und man nur noch schwarz sieht. Aufgehangen hat es sich allerdings nicht mehr und
dboxTV stürzte auch nicht mehr ab wenn ich zwischen TCP und UDP-Modus wechselte.

Ich werde nach dem Abendbrot weiter Testen.


Danke u. Gruß
Bt

31.01.2009 19:47 Bt ist offline Email an Bt senden Beiträge von Bt suchen Nehmen Sie Bt in Ihre Freundesliste auf
DsChAeK DsChAeK ist männlich
Administrator




Dabei seit: 14.09.2007
Beiträge: 1403

Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

Ok, also ich vermute das der Absturz bei UDP/HTTP-Wechsel von der VLC-Überwachung/EPG-Datenholung (Threads) kommt,
kann gut sein das da noch Fehler auftreten...ist das öfters/immer so, oder nur wenn die Systemlast steigt?
Bei der Testversion sind die beiden Threads deaktiviert, daher auch kein Update des Balkens.

Tritt das Problem mit der Systemlast auch mit der v1.0.0.15 auf?

Du kannst das folgendermaßen ohne dboxTV nachstellen, ich hoffe das ist genau genug erklärt:
1. VLC manuell öffnen ->STRG+N ->HTTP/HTTPS/... -> http://192.168.0.100:31339/0,0x0063,0x03FF,0x0400 eintragen
2. Unten rechts "Stream/Sichern" aktivieren -> Einstellungen -> HTTP aktivieren -> 127.0.0.1 eintragen und Port auf 31339 setzen
3. Ok drücken, VLC sollte jetzt was abspielen, es kommt aber kein Bild/Ton!
4. Weiteres VLC manuell öffnen ->STRG+N ->HTTP/HTTPS/... -> http://127.0.0.1:31339 eintragen
5. Ok drücken, VLC sollte jetzt Bild/Ton abspielen

Es laufen nun 2 VLC, das erste empfängt den Stream der Box, dupliziert diesen unter Port 31339 und das zweite VLC spielt diesen Stream dann ab.

Jetzt mal System auslasten und schauen was passiert.
Der Test ist nicht ganz das was dboxTV macht, da noch einige Parameter gesetzt werden, aber teste es einfach mal so.

Gruß
DsChAeK

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2

31.01.2009 23:25 DsChAeK ist offline Email an DsChAeK senden Homepage von DsChAeK Beiträge von DsChAeK suchen Nehmen Sie DsChAeK in Ihre Freundesliste auf
Bt




Dabei seit: 28.12.2008
Beiträge: 283

Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

Hi,

also deine VLC anleitung hab ich verstanden aber es hat nichts abgespielt.
IPs stimmen, Ports sind offen. Fehlt vieleicht noch irgendwas?


Gruß
Bt

02.02.2009 18:05 Bt ist offline Email an Bt senden Beiträge von Bt suchen Nehmen Sie Bt in Ihre Freundesliste auf
DsChAeK DsChAeK ist männlich
Administrator




Dabei seit: 14.09.2007
Beiträge: 1403

Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

Also wichtig ist, das der aktuelle Sender der Box richtig eingestellt ist.
Ich bin von deinem Logfile ausgegangen, leider hast du die Sender-Angabe abgeschnitten.

Starte einfach einmal dboxTV und schau im Log was für eine "LiveURL:" drinnsteht.

Gruß
DsChAek

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2

02.02.2009 18:51 DsChAeK ist offline Email an DsChAeK senden Homepage von DsChAeK Beiträge von DsChAeK suchen Nehmen Sie DsChAeK in Ihre Freundesliste auf
Bt




Dabei seit: 28.12.2008
Beiträge: 283

Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

Achso klar warum hab ich da nicht selber dran gedacht. Zunge raus
Hatte da natürlich einen anderen Sender an...

Hab jetzt nochmal getestet und glaube mir VLC läuft es etwas besser.
Sprich es ruckelt wehniger und der Stream reißt auch nicht ab wenn ich das Fenster
mehrere Sekunden resize also dem Prozess auslaste.

Mit dem alten dboxTV hab ich noch nicht getestet, hast du da vieleicht eine exe weil
das Setup geht bei mir nicht (Movefile fehlgeschlagen).


Gruß
Bt

02.02.2009 21:22 Bt ist offline Email an Bt senden Beiträge von Bt suchen Nehmen Sie Bt in Ihre Freundesliste auf
DsChAeK DsChAeK ist männlich
Administrator




Dabei seit: 14.09.2007
Beiträge: 1403

Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

Exe ist verschickt! Komisch, dass das Setup nicht funktioniert.

Also ich fasse mal kurz zusammen:

1.
Wenn der Stream ohnehin schon nicht sehr stabil läuft, dann ist er über dboxTV schneller negativ zu beeinflussen wie, wenn
er mit VLC direkt läuft. Beides hat aber Einfluss!
Evtl. läuft es über dboxTV schlechter, weil ich zwischen dem einen Stream-Start und dem Anderen zuwenig Delay drinnhabe,
und der Andere dann zugreift während der andere noch am cachen ist...Ich werde mir diese Stelle mal genauer anschauen!
Edit:
Vermutung wurde nicht bestätigt, liegt nicht am Delay zwischen den Streams!

2.
Es liegt auf jedenfall nicht an den Threads, da wir die ja schon in der aktuellen Version deaktiviert getestet haben.

3.
Es liegt nicht an der Timeshift Einstellung, das hast du auch schon getestet.

4.
v1.0.0.15 hat nur eine VLC Instanz, da sollte dein Problem hoffentlich nicht auftreten, ansonsten liegt es nicht an
dem Zusammenspiel der multiplen VLC-Instanzen im dboxTV v2.
Edit:
Tritt da wohl genauso auf, zumindest verhält es sich bei mir genauso.

5.
Teste bitte mal mit Prime95 (http://www.mersenne.org/ftp_root/gimps/p95v258.zip), da findest du unter
"Options->Torture Test -> Small FFTs" einen Test, der die CPU-Last gezielt hochjagt.
Ich habe es damit getestet und absolut gar keine Probleme mit dboxTV gehabt.
Edit:
Habe festgestellt das je länger dboxTV läuft, desto mehr "lost buffers" treten bei VLC auf, was im Endeffekt zu Probleme in
dboxTV führen könnte. Das hat bei mir aber irgendwie nix mit der Auslastung zu tun.
Ich sehe auch das VLC ohne dboxTV ein bischen stabiler zu laufen scheint.
-> Hackler treten in beiden Fällen auf, nur ausgelesenen Anzahl lostbuffers unterscheiden sich stark!

Gruß
DsChAeK

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2

Dieser Beitrag wurde schon 1 mal editiert, zum letzten mal von DsChAeK am 03.02.2009 09:11.

02.02.2009 22:16 DsChAeK ist offline Email an DsChAeK senden Homepage von DsChAeK Beiträge von DsChAeK suchen Nehmen Sie DsChAeK in Ihre Freundesliste auf
DsChAeK DsChAeK ist männlich
Administrator




Dabei seit: 14.09.2007
Beiträge: 1403

Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       IP Information Zum Anfang der Seite springen

Evtl. ist es auch ein Problem des Stream Bereitstellers, also deiner D-Box.
Wenn die bei Stream Wiedergabe zunehmend ausgelastet wird, dann kann das zu Empfangsproblemen führen.

Irgendwo in deinem Image müßte es eine System-Info geben, da siehst du genau die CPU-Last.

Gruß
DsChAeK

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2

03.02.2009 19:33 DsChAeK ist offline Email an DsChAeK senden Homepage von DsChAeK Beiträge von DsChAeK suchen Nehmen Sie DsChAeK in Ihre Freundesliste auf
Seiten (2): [1] 2 nächste »  
Neues Thema erstellen Antwort erstellen
Gehe zu:

Powered by Burning Board Lite 1.0.2 © 2001-2004 WoltLab GmbH