DsChAeK Forum (http://forum.dschaek.de/index.php)
- dboxTV (http://forum.dschaek.de/board.php?boardid=1)
-- Tips & Tricks, Tutorials (http://forum.dschaek.de/board.php?boardid=25)
--- UDP-Modus funktioniert nicht? (dboxTV-settings/udpstreamts) (http://forum.dschaek.de/threadid.php?threadid=47)


Geschrieben von DsChAeK am 14.10.2007 um 14:45:

Text UDP-Modus geht nicht? -> udpstreamts

UDP funktioniert nur mit "udpstreamts", wenn das nicht installiert ist, dann
muß man es manuell nachinstallieren.
Man kann es Hier runterladen, da ist auch eine Anleitung mit drinn!
Ansonsten gibt es hier aber auch noch eine neuere Version,
wo aber keine Anleitung dabei ist.


UDP-Modus funktioniert bis v1.0.0.15 nur mit v1.2 der api.sh!!!



In dboxTV müssen folgende Settings eingestellt sein:
Options->IP (PC), lokale IP-Adresse muß eingetragen sein.
Options->VLC->Stream Port UDP, muß auf z.B. 31330 gesetzt sein.


Ich werde das in neueren Versionen alles optimieren!

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2


Geschrieben von banjo am 30.10.2007 um 04:47:

also hat das tool keine auswirkungen auf das umschaltproblem im udp mode mit sagem boxen?

__________________

Philips D-Box2 (SAT)
Keywelt V1.1 April 2008 2x squashfs
yWeb v2.7.0.4
nhttpd/3.1.2 (yhttpd_core/1.2.0)
VLC v0.8.6i
WinXP SP3


Geschrieben von DsChAeK am 30.10.2007 um 09:16:

Genau, das ist beim keywelt image auch schon drauf, ohne das würde
gar kein UDP gehen.
In der nächsten Version wird man an einigen Delays rumspielen können,
evtl. liegt da das Problem. Es kann aber auch sein, daß ich seit der
funktionierenden Version die VLC-Befehlsfolge ein bischen geändert habe.
Dann müßte ich da mal ein bischen umbauen und euch testen lassen.

Ich habe auch schon angefangen ein kleines Test-Tool zu schreiben, mit
dem man manuell die VLC-Befehle und URLs nacheinander aufrufen kann,
damit könnte man sowas testen...ist aber noch nicht fertig.

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2


Geschrieben von banjo am 01.11.2007 um 00:39:

ja wäre wahnsinn wenn das für unsere "mecker"boxen dann funzen würde smile

__________________

Philips D-Box2 (SAT)
Keywelt V1.1 April 2008 2x squashfs
yWeb v2.7.0.4
nhttpd/3.1.2 (yhttpd_core/1.2.0)
VLC v0.8.6i
WinXP SP3


Geschrieben von DsChAeK am 23.11.2007 um 09:22:

Umschalten im UDP-Modus auf Sagem 1x Boxen ist jetzt auch möglich!
Einfach udpstreamts runterladen und nachinstallieren. (http://www.dschaek.de/index.php?s=dboxtv_links)

Zitat:

...ich habe nämlich udpstreamts nachinstalliert jedoch nur die anwendung nicht das dazugehörige script. im keywelt war kein udpstreamts vorhanden jedoch das script auf dem http server. wobei dieses auch nicht mit dem udpstreamts pack übereinstimmt. leider ist der http server ins keywelt als read-only filesystem eingebunden, somit konnte ich dieses script nicht überschreiben.

hatte danach udpstreamts gleich getestet ob es ansprechbar bzw. richtig installiert war. war es! habs dann udp ohne reboot probiert -> funzte nicht! habs nach nem reboot auch nicht wieder versucht und eben klick ich udp an und schalte rum und siehe da es funzt smile

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2


Geschrieben von FlaX am 23.11.2007 um 09:28:

Benutze das NG-Return 1.2 und damit geht auch kein UDP. Hab versucht udpstreamts nachzuinstallieren jedoch fehlen leider die Verzeichnisse wo die Dateien hinkopiert werden sollen.

Hat sonst jemand das NG-Return 1.2 und UDP zum Laufen gebracht? Möchte mich nur sehr ungern davon trennen.

__________________
Nokia D-Box2 (SAT)
IDE-Interface dbox2.com
NG Return 1.2

Nokia D-Box2 (Kabel)
IDE-Interface Hallenberg
NG Return 1.2
VLC v0.8.6c


Geschrieben von DsChAeK am 23.11.2007 um 09:32:

ahh, ok, also dann werde ich mir auch mal das NG Return draufmachen und
testen ob es bei mir geht. Ich hatte bisher weder mit Keywelt noch mit
BluePeer Probleme. Wäre ja schön wenn ich das auch mal nachvollziehen
könnte.

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2


Geschrieben von DsChAeK am 23.11.2007 um 21:59:

Also auch mit dem NG-Return Image habe ich keinerlei Probleme mit dem
UDP-Modus.

udpstreamts liegt dort unter:
/sbin/

api.sh liegt dort unter:
/share/tuxbox/neutrino/httpd-y/scripts/

Backup schadet vorm ersetzen nicht! smile

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2


Geschrieben von FlaX am 24.11.2007 um 10:58:

Danke ich werds später gleich mal ausprobieren.

__________________
Nokia D-Box2 (SAT)
IDE-Interface dbox2.com
NG Return 1.2

Nokia D-Box2 (Kabel)
IDE-Interface Hallenberg
NG Return 1.2
VLC v0.8.6c


Geschrieben von FlaX am 24.11.2007 um 12:16:

So hab die beiden Files mal ausgetauscht.

Wenn ich jetzt UDP auswähle läd das Programm zwar den Cache neu und danach kommt nur ein schwarzes Bild.

__________________
Nokia D-Box2 (SAT)
IDE-Interface dbox2.com
NG Return 1.2

Nokia D-Box2 (Kabel)
IDE-Interface Hallenberg
NG Return 1.2
VLC v0.8.6c


Geschrieben von DsChAeK am 24.11.2007 um 12:20:

hm, dann funktioniert es wohl nicht.
Hast du mal die Anleitung, die hier
dabei ist durchgelesen und mal manuell im Browser getestet ob
das so bei funktioniert?

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2


Geschrieben von FlaX am 24.11.2007 um 12:28:

Ja hab ich also beim ersten Test via Telnet kommt " -sh: /var: Permission denied "
(oder muss ich den Befehl " /var # udpstreamts " noch abändern ?)

beim zweiten Test kommt nur eine weiße Seite

wenn ich allerdings die beiden alten Dateien auf dem NG-Return belasse bekomme ich wenigstens beim 2. Test die gewünschte "1.0" auf den Bildschirm ausgegeben.

__________________
Nokia D-Box2 (SAT)
IDE-Interface dbox2.com
NG Return 1.2

Nokia D-Box2 (Kabel)
IDE-Interface Hallenberg
NG Return 1.2
VLC v0.8.6c


Geschrieben von DsChAeK am 24.11.2007 um 12:37:

Zitat:
Ja hab ich also beim ersten Test via Telnet kommt " -sh: /var: Permission denied "
(oder muss ich den Befehl " /var # udpstreamts " noch abändern ?)"


das liegt daran das die syntax nicht stimmt. Deine Pfade sind auch anders!
Versuchs mal mit Eingabe von:
"/sbin/udpstreamts"

Der zweite Test reicht eigentlich aus, da er ja auch diesen Aufruf startet.
Ich gehe mal davon aus, das du die Rechte mit chmod auf 755 gesetzt hast,
das wäre auch eine Erklärung für schwarzes Bild.

Ansonsten ersetze einfach mal die udpstreamts und lass das api.sh beim alten.

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2


Geschrieben von FlaX am 24.11.2007 um 12:59:

Also das Bild bleibt schwarz. Habe die alte api.sh wieder zurückgespielt, Rechte sind und waren auf 755

Bei Test 1 bekomme ich:
Zitat:
~ # /sbin/udpstreamts
udpstreamts starting...

usage: /sbin/udpstreamts [-b ] [ ...]


bei Test 2

Zitat:
1.0


Bild bleibt aber unverändert schwarz das zappen funktioniert jedoch weiterhin.

__________________
Nokia D-Box2 (SAT)
IDE-Interface dbox2.com
NG Return 1.2

Nokia D-Box2 (Kabel)
IDE-Interface Hallenberg
NG Return 1.2
VLC v0.8.6c


Geschrieben von DsChAeK am 24.11.2007 um 13:30:

hm, das ist komisch...ich hatte das nur wenn die Rechte falsch waren, zumindest bilde ich mir das ein.
Evlt mal mit dem modifizierten udpstreamts testen, das gibts unter
http://neutrinotv.homeip.net/index.php?view=category&id=43%3Amisc&Itemid=59&option=com_content

Es gibt auch die Möglichkeit den UDP-Stream manuell, ohne dboxTV zu testen, also mit Browser und VLC.
Im Prinzip macht dboxTV aber genau das schon automatisch!

1. Infos holen um die URL zu basteln
http:///control/zapto?getallpids

listet alle aktuell verfügbaren Pids auf.
z.B.
00167 (0x00A7)
00136 German (0x0088)
00071 vtxt (0x0047)
00047 pmt (0x002F)

2. UDP Stream Start-URL zusammensetzen
http:///control/exec?api udp_stream start 0 0x002F 0x00A7 0x0088

z.B.
http://192.168.0.9:99/control/exec?api udp_stream start 192.168.0.1 31330 0 0x002F 0x00A7 0x0088

3. Stream starten
-VLC starten
-Datei->Netzwerkstream öffnen
-dort unten bei "anpassen:" folgende Zeile einfügen
udp://@192.168.0.1:31330
-Optionen schließen und Play drücken
-Browser öffnen und Stream Start URL ausführen
http://192.168.0.9:99/control/exec?api udp_stream start 192.168.0.1 31330 0 0x002F 0x00A7 0x0088

Stream sollte von VLC jetzt abgespielt werden!
Der Browser läd solange die Seite, bis man VLC wieder gestoppt hat.

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2


Geschrieben von DsChAeK am 25.11.2007 um 04:47:

Ich denke du hast dasselbe Problem wie heute jemand in einem anderen Forum.
Ist bei dir unter
Options->IP (PC), deine lokale IP-Adresse eingetragen?
und unter
Options->VLC->Stream Port UDP, auf z.B. 31330
gesetzt?

Ich gebe zu das muß ich intuitiver machen, weil es keiner wissen kann. smile

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2


Geschrieben von FlaX am 25.11.2007 um 15:34:

OK die IP des PCs hat wirklich gefehlt jetzt hab ich auch Bild und Ton smile Also der Stream läuft viel flüssiger gerade bei ARD/ZDF ORF usw.

Aber was bei mir noch Probleme macht ist das deaktivieren von UDP. Da hängt sich dboxTV auf und beim Neustart kommt keine Verbindung zur Box mehr zustande. erst wenn ich die Box neustarte.

Außerdem kommt es auch öfters nach einiger Zeit zum Streamabbruch der durch umschalten wieder hergestellt werden kann. Das hast du aber glaube ich schon erwähnt.

__________________
Nokia D-Box2 (SAT)
IDE-Interface dbox2.com
NG Return 1.2

Nokia D-Box2 (Kabel)
IDE-Interface Hallenberg
NG Return 1.2
VLC v0.8.6c


Geschrieben von DsChAeK am 25.11.2007 um 15:49:

Zitat:
Aber was bei mir noch Probleme macht ist das deaktivieren von UDP. Da hängt sich dboxTV auf und beim Neustart kommt keine Verbindung zur Box mehr zustande. erst wenn ich die Box neustarte.

Beim stoppen des streams wird folgendes ausgeführt:
1. VLC_Stop(), um den Player zu stoppen
2. http:///control/exec?api udp_stream kill_all_streams um den stream zu stoppen

Wenn eines von beiden nicht funktioniert, dann schießt man die Box ab.
Versuch es einfach mal manuell auszuführen, dann siehst du wo es hängt.
VLC_Stop() kannst du ja über das dboxTV-Menü ausführen während der stream läuft.

Und prüf evlt. mal ob der Befehl "kill_all_streams" in der "api.sh" auch so drinnsteht.

Zitat:
Außerdem kommt es auch öfters nach einiger Zeit zum Streamabbruch der durch umschalten wieder hergestellt werden kann. Das hast du aber glaube ich schon erwähnt.

Ich bekomme selbst nur sehr viele Artefakte ins Bild, deshalb nutze ich den Modus kaum. Ein Abbruch kam aber noch nie vor. Ich denke das liegt evtl. am Netzwerk oder am udpstreamts!? Ist das mit z.B. NeutrinoTV, oder wenn du es manuell im VLC startest, auch so?

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2


Geschrieben von banjo am 26.11.2007 um 18:37:

UDP geht nicht mehr LOL

ich glaube schon ich spinne! funzt nicht mehr, zumindest das umschalten!

__________________

Philips D-Box2 (SAT)
Keywelt V1.1 April 2008 2x squashfs
yWeb v2.7.0.4
nhttpd/3.1.2 (yhttpd_core/1.2.0)
VLC v0.8.6i
WinXP SP3


Geschrieben von DsChAeK am 26.11.2007 um 20:17:

Mist, und ich dachte es wäre gelöst :/

Wenn das mal jemand manuell durchspielen könnte, dann wäre mir
sehr geholfen. Ich vermute es liegt am "kill_all_streams"...

__________________
dboxTV
Philips D-Box2 (SAT)
BluePeer v1.2.1
yWeb v2.7.0.4
nhttpd/3.1.8 (yhttpd_core/1.2.0)
VLC v0.8.6h
WinXP SP2

Powered by: Burning Board Lite 1.0.2 2001-2004 WoltLab GmbH